Category Archives: hacks

WiFi Issues with Kindle Fire HD

[note: post updated on 12/29 with a possible fix, see below.  Let me know if it works for you.] Kindle Fire HD

I got my wife a Kindle Fire HD for Christmas and have been working on setting it up for an hour or two today (off and on).  I am a fan of Amazon.com and have owned Kindle’s in the past (I currently use an iPad 2 as my preferred tablet device), and was surprised to run into WiFi issues during the setup.

I connected to my home WiFi just fine, but going through the device registration (to my wife’s Amazon account), it would fail.  I would go back, say register later and start troubleshooting the wifi.  Any time I would reconnect to wifi, it would work for a few minutes (browse the web, do a search in the app store, etc), but almost immediately it would drop the wifi connection.  The Kindle would show that it was still connected to WiFi, with a strong signal (and a valid Internet connection – as there was no little white “X” in the wifi signal strength icon that means no connection to the Internet).

The temporary workaround was to either shut-off WiFi on the Kindle, and then turn it back on and let it reconnect and use the connection for a minute or two.  Or, essentially the same thing, turn on Airplane Mode and then turn it off again.blue_wifi

My wife was getting frustrated that all other devices in our house seem to work fine, but she would not use the Kindle if she had to do this every few minutes.  I can’t say I blame her.

Searching the Internet I found a suggestion to change the wireless router channel (I was originally on channel 7, switched to 11, 1, 2 etc, none of which worked).  I fiddled with a few other router settings, but could not get anything to keep the Kindle connected.

So I called Amazon tech support.  After just a few minutes of explaining my problem and the Kindle’s behavior to the level 1 support analyst, she put me through to a level 2 technical support person.   He seemed familiar with the problem, and described that it was related to my wireless security options.

I am running a NetGear WNR3500L router with WPA2-PSK.  My passphrase is what I was putting in the Kindle Fire HD during WiFi setup.  The Kindle was taking my passphrase just fine, and authenticating, but apparently drops the authentication (or key) somewhere along the way after using it a while.  You need to put in the actual WPA key instead of the passphrase.  Ok, great.  The nice thing is the Kindle doesn’t really tell you this, nor does the Amazon Kindle online help (at least not very clearly).

Getting my 64 char length hex WPA key (from my passphrase) was another ordeal, and will save that for another post if needed.  Assuming you can obtain your hexadecimal key, and have the patience to type it into the Kindle Fire, you should authenticate fine and stay up and running.  At least ours has for about an hour or two.  Fingers crossed this was the actual solution, and it won’t start dropping the connection again.

Update 12/29 #1:

Sadly, the full hex key did not work as a permanent solution.  It seemed to keep the Kindle Fire connected longer, but in the end it still dropped the WiFi connection – same as before.  As I commented below, I am still looking for a permanent solution.  As a temporary solution, I set up my WiFi routers Guest network, and set the security for that to be WEP.  The Kindle Fire HD seems Ok with my WEP security, it has not dropped at all since set up (it has been a few days).  As it is a guest network, I hid the SSID and going to set up MAC filtering to help prevent intruders (not too worried, as we live in a pretty remote area).  This also helped prevent me from changing my main access points security, which would have meant reconnecting countless devices throughout the house.  So all devices are happy for now.  I do wish that Amazon would push out an update for this bug, or at least acknowledge it on their online help.

Is anybody out there running Kindle Fire HD versions with WPA-PSK just fine?  I would imaging many are, and it is something to do with my router or network setup; however it would be good to get confirmation on what configurations the device seems to work fine for WPA-PSK.  If you feel like dropping a comment below, it would be appreciated.

Update 12/29 #2:

I “borrowed” my wife’s Kindle to play around with the wifi router setting some more.  I noticed another option on my WiFi security settings which was worth a try.  Here are the security options that my router supports:

  • None   (not recommended!)
  • WPA-PSK [TKIP]
  • WPA2-PSK [AES]   <== previously selected, and how all other devices in the house were previously authenticated against
  • WPA-PSK [TKIP] + WPA2-PSK [AES]  <== I just switched to this, using the same passphrase as before

I am not sure why I did not think of running the 4th option (which supports clients running WPA2-PSK and WPA-PSK simultaneously).  If this worked, it would allow my currently connected devices to continue using WPA2-PSK [AES] and not disconnect them (I am no WiFi expert, so I am not sure if they would reconnect fine with the same stored key or passphrase had I done a full switch over to WPA-PSK [TKIP].   So I tried the switch over to  “WPA-PSK [TKIP] + WPA2-PSK [AES]” mode and used the same passphrase as before.  My laptop and phone reconnected just fine (after the router restarted the wifi AP).  The Kindle connected just fine (with passphrase, I didn’t try the full 64-char hex key this time).  It has stayed connected over 30 minutes now (which is longer than the 1 – 2 minutes I would get before being dropped).  Third time is a charm, let’s see if this works as a long-term secure option.  Let me know if it works for you.

Get Your Fujitsu ScanSnap S510 Working on Mac OS X

I recently got a Mac Book Pro, my first Mac actually, and was trying to get my ScanSnap S510 scanner to work.  I came across two very useful posts:

Use a Windows PC Fujitsu ScanSnap scanner on the Mac

Fujitsu ScanSnap s510 Hack Download

After about an hour, i got some of the software working while following those initial instructions.  Unfortunately I hit a show-stopping error.  As others were, I was getting the error code 0xffffdc7 after every scan.  It wasn’t working.

A little more research, and realized that Fujitsu put out a patch for OS X 10.7 ( scansnap download V22L24) which needed to be applied to resolve that issue.  A little bit of work this afternoon, grabbing the all the English resource files needed and applying them to the newly patched Japanese version…. and it works!

For now at least, until somebody releases a new patch.  You can download the package here.

%d bloggers like this: